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Fixplot Instruction Manual

 (data plotting program)
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1. Introduction
The Fixplot program is a component program of Eyenal that allows the user to plot eye position
data collected with Applied Science Laboratories series 4000, 5000, and model ETS Eye
Tracking systems. Raw data  (.eyd or .ehd files) and calculated fixations ( .fix files) can be
plotted over any bitmap image. This manual will explain the process of plotting scan paths over
bitmap images, graphical options for the scan path displays, and creating and working with Area
of Interest files. In most but not all cases the bitmap image used will be of the scene the subject(s)
viewed while data was recorded. This manual will describe methods for capturing a scene image
and saving it as a bitmap (.bmp) file to be used in Fixplot. It is not necessary to have a frame
grabber in order to use FixPlot. It is only necessary to have bit-map files on which to
superimpose fixation scan path data.  These files can come from any source.
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2.1.1 Model ETS PC eye tracker
In the case of a model ETS PC eye tracker it is necessary to use the ETS2EDT.EXE Conversion
Utility. This utility converts an ETS data file to an EYEDAT data file for use in Eyenal and
Fixplot.

Below are directions for using the conversion utility.
 
The command line syntax is as follows:

 ETS2EDT [/U:hertz] [/T:hertz] inpfile [outfile]

/U:hertz    Specifies the ETS update rate in Hertz.
/T:hertz    Specifies the ETS tick rate in Hertz.
inpfile     Specifies the input ETS file.
outfile     Specifies the output EYEDAT file.

 The input file can be either a binary or ASCII formatted ETS
file.

 If you don't specify an output file, the name of the input file
 is used with a .eyd extension.

 If you specify an output file but don't specify an extension,
.eyd

 is appended to it.

 The update rate defaults to 50 Hz.

 The tick rate defaults to 64 ticks per second.

 The tick value in each ETS data file record is converted to a
 video field count in the EYEDAT data file.

 The comment value in each ETS data file record is converted to
two

 values in the EYEDAT data file.  The most significant three
digits

 of the comment value are stored as an xdat value and the least
 significant digit of the comment value is stored as a mark

value.
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3. Steps for using FIXPLOT
Note:  Instructions for use of EYEHEAD™ Integration data acquired with Head
Mounted Optics and a head tracker, are provided in Section 4

3.1 Coordinate Transform

In order for Fixplot to correctly plot fixations over an image a coordinate transform is required.
This is a transform between the coordinates used to record eye position”(Eye Tracker
coordinates) and those native to the image (ex. pixel coordinates).

The Coordinate transform has 2 conditions. 
Condition 1: requires that the user provide two “attachment points” whose coordinates are
known in Eye Tracker units. Valid Eye Tracker coordinates are between (0,0) and  (240,260). 
Condition 2: requires that the two “attachment points” be identified on the image. Moving the
mouse over the location of each point and clicking with the mouse identifies attachment points.

Both conditions are easily met by using the Calibration display.  

Below is the recommended procedure for the Coordinate transform

1. Write down eye tracker coordinates for calibration point 1 (upper left) and point 9 (lower
right). 

• For an ASL model 5000 eye tracker:
 Use the “Check Target Points” selection under the
Calibrate menu of ASL interface program e5win to
display the locations of points 1 and 9, and read the
coordinates from the Set Target Points window; (scene
POG h:nnn v:nnn).  This procedure assumes that the
Calibration Target Points have been previously set as
described in the model 501or 504 Manual.
 

• For an ASL model ETS Eye Tracker use the Wind
Screen setting function to manually move the cursor
first to point 0 and then to point 8, and read the
corresponding coordinates from the terminal screen.

2. Capture the calibration display as a bit-map file.
NOTE:  It is important that the calibration display
be captured at the same resolution and size as it was displayed when calibrating and running
subjects for data collection.

 
- If using a computer to show the calibration display (PC or MAC)
If the image is being displayed on a computer screen, it may already be available as a bit-map
image file.  If not, the “Print Screen” function can most likely be used to capture a screen image. 
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 To capture a “screen shot” on a PC with MS Windows:

• press Print Screen button on the keyboard to save the current screen image to the clipboard
• Run MS Paint (or some other utility that

manipulates bit-map images) Paint can
be found on most Windows OS’s by
opening the Start menu, clicking on
programs and then on Accessories. 

• Paint should be listed in the Accessories
drop down list. Double click to open the
program.

• Click Edit and select Paste.
• Click File and select “Save As” to store

the image as a Bitmap file. (see picture) 
• This file can later be transferred to any

PC running Fixplot.
 

3. Run FIXPLOT

4. Select “Open image’ (from File menu)
and open the Calibration display bitmap
file.

5. The “Attach coordinates” windows should automatically open. If it does not  Select “Attach
coordinates” from the Tools menu.

6. Enter point 1 coordinates in the H1= and V1= text box
and point 9 coordinates in the H2= and V2= text box.
NOTE: these coordinates should be stored in the Interface
program as indicated in step 1.

7. Check the “Set attachment as default” box!

8. Be sure that “Scene Plane” is set to 0 (other scene plane
numbers apply only to EYEHEAD Integration data). 



9. Click on Calibration Point 1 and Calibration Point 9 in the image:
NOTE: Once OK has been selected in the Attach Coordinates  pop-up menu, the cursor will
now be a small cross hair with “P1” displayed next to it as shown above. Place the cross
hair over the center of point one and click. Next the small cross hair will be labeled “P2”.
Place over point 9 and click.

10. Once both Attachment Point 1 and 2 are placed the Coordinate transform is complete. The
same transform information can be applied to each subsequent bitmap opened in Fixplot by
selecting the “Use Default” button from the Attach Coordinate System pop-up menu. 
5

!!CAUTION!!
The default coordinate system option
will only work for subsequent
bitmap(s) which were captured using
the technique as was employed to
create the calibration image bitmap. In
other words all bitmap files must be
captured in a consistent manner.
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3.2 Plot fixations (.fix files) on captured screen images
1. Select Open image (from file menu) and choose one of the saved screen images (bitmap file).  

2. Click “use default” button on “Attachment coordinates” pop up window.

3. Select “Append Fix-AOI” from file menu and select the relevant fixation file for the current
image.

                             NOTE: More than one fixation file can be appended to a single image

4. Right click on a fixation point in the scan path to access a drop menu with specific options for
the plotted data.

A) The Output type dialog window allows
display of only a subset of fixations.  For
example, select the “number limit” radio
button and specify display of fixations 10-20.
If the integer n is typed in the  “step” box
(after selecting the “number limit” radio
button) only n fixations will be displayed.  In
this case, clicking the right arrow symbol on
the menu will cause the next n fixations to be



displayed instead, and the left arrow will cause the previous n fixations to be displayed.
However only fixations between the “from” and “to” numbers will ever be displayed.  If the
“time limit” radio button is selected time boundaries and a time step size can selected in a
similar fashion. 

B) The File Drawing Properties dialog window allows modification of :

• the fixation dot shape and color

• the fixation path line shape and color

• fixation point labels (none, fix number, fix duration,
etc.).  Furthermore, the fixation point indicators can
be fixed size, or can have a size that is proportional to
fixation duration.  In the latter case the range for
which proportionality is computed can be specified.
A fixation shorter than the range minimum is
presented at the same size as the range minimum
fixation.  Any fixation longer than the specified range
maximum is presented with the same size indicator as
the specified maximum duration fixation.
7

(Note: if the scan path has not appeared on the
display, right click on the display and select
“Properties”, as described above, to be sure that
visible fixation point symbols and connecting lines are selected.  If the “connect points”
check box is not checked, and the “Points, type:” designation does not include a fixation
symbol, then nothing will be shown.  Be sure that “connect points” is checked, and/or the
“Points, type:” choice includes a fixation point symbol, rather than just connection
lines.)

5. If desired draw area of interest (AOI) boxes on the image as described in the next section.
The AOI pattern can be saved as a *.aoi file (also described in the next section).

6. If desired super impose additional fixation files by repeating step 3 above.  Select
“Show/hide” form the “View” menu to select which fixation segments or AOI files to
display.  To change “Properties” or “Output type” with multiple FIX and AOI files attached,
first choose “Select…” from the edit menu or from the pop up box that appears in response to
a right click on the image, highlight the FIX or AOI file to be manipulated, and click OK.
Then right click on the image to select the properties or “Output type” dialog.  In this way it
is possible to plot the fixation path for one fix file with blue lines and for another with red
lines, etc.

7. Select Save As to save the result as an “*.eye” file.
NOTE: “*.eye” files retain links to associated *.fix files and *.aoi files.  They can be reloaded
by FIXPLOT and manipulated in the usual ways using the “Output type” and ”Properties”
dialog boxes, etc.

8. To save the resulting images from Fixplot, select “Save as image” from the File menu.

9. Repeat steps for other screen images.

3.3 Drawing or loading Areas of Interest
To draw area of interest (AOI) rectangles on the image:
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1. Select “Input AOI” from the “Tools” menu.  The mouse cursor will change to a box draw
symbol when over the image.

2. Use the left mouse button to drag the mouse cursor and create a
rectangular box.  When the cursor is released, a pop up window
appears to request an area name.  Type in a name and click OK to save
the AOI box, or click “Cancel” to cancel the box just drawn.  If “OK”
is clicked the AOI box will appear superimposed on the image.  

3. Repeat step 2 for as many AOIs as desired, up to a maximum of 50 per
image.  When through drawing AOIs, right click over the image area to
make the mouse cursor revert to the standard arrow.

4. To change the AOI line color, to specify a fill pattern or color, or to
display labels for the AOI boxes, choose “Select” from the Edit menu,
highlight “new AOI:” (or the AOI file name if AOIs were loaded from a file as described
below) and click OK.  Then right click on the image area and choose “Properties” from the
pop up dialog box.  Modify the line, fill, and label properties as desired. 

5. To display a subset of the AOIs, choose “Show/Hide” from the “View” menu.  The box next
to each item on the tree is green if the item is to be shown, and gray if it is to be hidden.
Clicking on the boxes toggles them between green and gray. 

6. To save the AOIs as a *.aoi file, choose “Save AOIs” from the “File” menu.
           HINT: At this stage t is convenient to name and save the current plot as a *.eye file.
A pop up box will ask if the areas should be saved as an AOI file as well.  A yes response
results in a dialog box for naming the AOI file.
Once a collection of AOIs is saves as a file it can be used by Eyenal to compute further
statistics. 

3.3.1 Loading previously saved AOI files:
Choose “Append Fix-AOI” from the “File” menu and select the desired *.aoi file.
Be sure to select  Area of Interest (.aoi) from the File type drop down list in the resulting pop-up
menu.

3.4 Viewing Fixation Files (text format)
To view, in text format, a fixation file that has been appended, select “Fix Files” from the “View”
menu. Click on the desired fixation segment at the left of the resulting display window, and the
data for that segment will appear in the scrolling display window.  This feature allows a quick
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check of digital fixation coordinates, and can be very convenient if fixation points do not appear
where expected on the plot. 

3.5 Additional Features
Global Settings 

“Preferences” and “Output Types” can be set globally to apply to all fix or AOI files.  Select
“Preferences” from the “Options” menu.  Select the tab labeled “Other”. Settings made in the
Options, Preferences dialog window under the “FIX drawing” tab will apply to all attached FIX
files, and settings under the “AOI drawing” tab will apply to all AOI files, etc.  Furthermore,
settings in the Options, Output Type dialog window will apply globally to all FIX files.
Properties and Output Type settings are individually determined for each file by right
clicking a fixation point belonging to a particular fixation file to select an individual
“Properties” or “Output Type” dialog box.  
“Other’ menu tab in the Properties pop-up menu  

• Show attachment points Check box

Display of the (Options, Preferences, Other,
Attachment point) file attachment points (P1 and P2)
can toggled on or off by selecting Preferences from
the Options menu, and choosing the “Other” tab.
Check the box labeled Attachment point to show the
attachment point labels or uncheck the box to hide
them.  

• Coords for Plane Check box

When this box is checked the Eye Tracker coordinates
for the current mouse position on the image is
displayed. (see figure 1) 

•   “Default delta zoom coefficient” item under the
same tab determines how much the display will
grow or shrink when the “zoom in” or “zoom out”
buttons are used.  

The “zoom in” and “zoom out” buttons are a magnifying glass symbol with a plus or minus sign
respectively . (see figure 1).  If the “zoom in” button is clicked the mouse cursor changes to a
magnifying glass symbol when over the image area and left clicking will magnify the display by
the percent set under “default delta zoom coefficient” as described in the preceding paragraph.
The “zoom out” button has the opposite affect (display shrinks by the same percent).  Right
clicking when over the image area will cause the mouse cursor to return to the standard arrow.

Attached Fixation files or AOI files can be deleted by selecting “Delete” under the “Edit” menu,
highlighting the file to be deleted, and clicking OK.  Other functions under the Windows and File
menus are the standard windows functions.
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 of FIXPLOT with EYEHEAD Integration data

*Applies only to Model 501 Head Mounted Optics with Head Tracker*

D integration data expresses points of gaze in physical units (inches or centimeters)
ct to true Cartesian coordinate frames defined on one or more scene surfaces.  The data
age pixel coordinates. EYEHEAD data files are identified by a “.ehd” file extension.
 can still be used to draw corresponding scan plots on bit map images so long as the bit
es have vertical and horizontal axes that are aligned with the axes of the coordinate
igned to the surface, and so long as distance proportions are consistent.  

or example points that have the same horizontal coordinate on the scene plane
ordinate frame must also have the same horizontal pixel coordinate (be on the same
orizontal scan line”) on the bit map image.  Points that are spaced at equal horizontal

istances with respect to the scene plane coordinate frame must also be represented by
ually spaced positions on the bit map image.  

age capture
ages may be acquired by capturing the same signal being viewed by the subject.  If the

 viewing a video signal (on a monitor), the composite video signal may be captured by a
bber and saved as a bitmap.  If the subject is viewing an image on a computer monitor
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(VGA, etc.), the computer generating the image can capture and save it as a bit map or the image
may already be available as a bit map file. 

Note:  images captured as so far described will generally correspond to a single scene
plane surface.  In order for such images to be used properly by FIXPLOT, be sure that
when defining scene plane coordinates (as described in the EYEHEAD integration
manual) the horizontal (y) and vertical (z) coordinate axes assigned to the monitor
surface line up with the monitor scan line orientation.  

Note: any large spatial non-linearities in the monitor will result in errors in the scan plot
produced.  For example if there are a significantly different number of pixels per inch
near the left edge of the monitor than near the right edge, then the image pixel data will
not line up quite properly with the eye tracker data no matter what scale factor is applied.  

If the subject is not looking at a video or computer generated image, a video camera (connected to
a frame grabber) may be used to capture an image of the scene being viewed, or a computer
drawing program may be used to create a drawing of the scene in bit map form.  In this case take
special care that EYEHEAD scene surface coordinate frames and the image pixel axes are
properly aligned and have the same spatial proportions.  If a camera is used, it should be aimed
along an axis perpendicular to the surface and positioned directly in front of the surface center.
An attempt should be made to orient the camera so that the camera scan lines align with the
horizontal axis assigned to the surface.  If the camera views the surface from a significantly
skewed angle, the resulting perspective distortion of the image cannot be accounted for by
FIXPLOT.  

4.2 Plotting EYEHEAD data
The EYEHEAD coordinates must be known for at least two points that are identifiable on the bit
map images, and the two points must have significantly different vertical and horizontal
coordinate values (I.e., they must be separated along both the vertical and horizontal axis).
Remember that EYEHEAD coordinates are determined by measuring the position of points on
the physical surface with respect to the physical origin of the coordinate frame assigned to that
surface.

Use of the FIXPLOT program is the same as described in section 3, except that when the “Attach
Coordinate System” function is used the proper scene plane number must also be assigned.  If  the
bit map image shows only scene plane zero, there is no difference from the section 2 procedure.
Remember that it is the EYEHEAD coordinates for two points that are typed into the “attach
coordinates” dialog window. These coordinate values are expressed in the same way that
calibration points 1-9 are defined in the EYEHEAD Setup, “Calibration Scene Plane” menu
procedure. One thing that maybe slightly confusing is that FIXPLOT calls the horizontal and
vertical  axes “x” and “y:” respectively, whereas the EYEHEAD program and manual refer to the
horizontal and vertical axes as “y” and “z” (the x-axis points out the back of the scene plane
surface).  When typing in coordinates for the two points required by FIXPLOT, in the Attach
Coordinate System dialog window, the EYEHEAD horizontal (EYEHEAD y) coordinate is
entered in the dialog window under “X1” for the first point or “X2” for the second.  The
EYEHEAD vertical (EYEHEAD z) coordinate is entered next to the “Y1” or “Y2” label in the
Attach Coordinate System dialog window.  It is probably less confusing to simply think of the
axes as “horizontal” and “vertical”. 
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4.3 Coordinate Transform

In order for Fixplot to correctly plot fixations over a “surface” a coordinate transform is required.
This is a transform between the coordinates used to record eye position”(inches or cm) and those
native to the image (ex. pixel coordinates).  Furthermore each surface defined in the EYEHEAD
environment requires an individual coordinate transform. 

The Coordinate transform has 2 conditions. 
Condition 1: requires that the user provide two “attachment points” whose coordinates are
known in physical units (inches or centimeters) with respect to true Cartesian. 
Condition 2: requires that the two “attachment points” be identified on the image. Moving the
mouse over the location of each point and clicking with the mouse identifies attachment points.

Below is the recommended procedure for the Coordinate transform of the Calibration Scene
plane (a.k.a. plane 0)

Condition 1 is easily met by using the information stored in the e5000.env file. 
This file stores information about the Environment (coordinate frames defined on one or more
scene surfaces) defined to the system before data recording.

Information is entered into this file through the EYEHEAD Setup menu in the User
Interface program

1. Write down eye tracker coordinates for calibration point 1 (upper left) and point 9 (lower
right). 

• Open the EYEHEAD Setup menu in the User Interface Program (e5win or E5Vid)
Select the “Calibration Scene Plane” menu tab 

Copy the Y(Horizontal) and Z(Vertical) coordinates for points 1 and 9

2. Capture the calibration display as a bit-map file or draw a scaled diagram.
NOTE:  It is important that the calibration display be captured at the same resolution and
size as it was displayed when calibrating and running subjects for data collection.

 
3. Run FIXPLOT

3. Select “Open image’ (from File menu) and open the
Calibration display bitmap file.

4. The “Attach coordinates” windows should automatically
open. If it does not  Select “Attach coordinates” from the
Tools menu.

5. Enter point 1 coordinates in the H1= and V1= text box and
point 9 coordinates in the H2= and V2= text box.

6. Be sure that “Scene Plane” is set to 0 

7. Click on Calibration Point 1 and Calibration Point 9 in the
image:



On

4.4
Im
wit
sce
pro
two
ma
ima

If t
sur
coo
sec
Sys
typ
poi
cor
sce
Pla
13

NOTE: Once OK has been selected in the Attach Coordinates  pop-up menu, the cursor will
now be a small cross hair with “P1” displayed next to it as shown above. Place the cross
hair over the center of point one and click. Next the small cross hair will be labeled “P2”.
Place over point 9 and click.

ce both Attachment Point 1 and 2 are placed the Coordinate transform is complete for plane 0. 

 Multiple Planes
ages containing images of more than one scene plane surface can be used so long as 2 points
h known EYEHEAD coordinates are identifiable for each scene plane surface.  As with one
ne plane is also require that pixel axes are aligned with scene plane coordinate axes and spatial
portions are maintained within each surface image.  For example if the subject is looking at
 computer screens, an image from each screen can be captured as described above, and a bit

p editing program (such as Corel Photo-Paint, or Microsoft Imager) can be used to place the
ges, side by side, on a single bit map image file.  

he bit map image contains multiple scene plane
faces, first open the bit map image and attach
rdinates for scene plane zero just as described in
tion 2.  Next, select “Tools, Attach Coordinate
tem”, be sure that the “Scene Plane” is set to 1, and
e in the horizontal and vertical coordinates for  the two
nts on plane 1.  Click OK; then left click on the two
responding points in the bit map image.  If there is a
ne plane 2 in the image, repeat the process with “Scene
ne” set to 2 in the Attach Coordinate System dialog.  
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FIXPLOT will not accept coordinate frame attachment out of scene plane order.  
If, for example, the bit map image shows only scene plane 1, it is still necessary to first

attach coordinates for scene plane 0.  On the Attach Coordinate System dialog window, with
“Scene Plane” set to 0, enter P1 coordinates that represent the most upper left corner of plane 0
on which you would expect a fixation.  For P2 enter coordinates of the most lower right point at
which you would expect fixations, and click OK.  Choose a corner or place along the edge of the
image that was unlikely to have been fixated, and click two very closely spaced positions at the
upper left and lower right of that point.  Any fixations on plane zero will be plotted at that point.
Proceed to attach plane 1 coordinates in the normal fashion.
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